flutter doctor -v 오류 ("✗ Unable to find bundled Java version.")

Android Studio (version 2022.1) / "Electric Eel | 2022.1.1" 설치 후 flutter doctor 실행하면 발생하는 문제 - 오류 발동 $ flutter doctor -v - 오류 내용 [!] Android Studio (version 2022.1) ... ✗ Unable to find bundled Java version. - 해결 방법 -- Windows 1. Android Studio가 설치된 곳으로 이동 C:\> cd "C:\Program Files\Android\Android Studio") 2. Symbol link 생성 (다음 중 한가지로) 2.1 Command Line C:\Program Files\Android\Android Studio> mklink /d .\jre .\jbr 2.2 PowerShell PS C:\Program Files\Android\Android Studio> New-Item -ItemType SymbolicLink -Path .\jre -Target .\jbr -- macOS 1. Android Studio가 설치된 곳으로 이동 cd "/Application/Android Studio/Contents" 2. Symbol link 생성 $ ln -sv jbr jre - 확인 $ flutter doctor -v - 참고 -- Flutter: https://docs.flutter.dev/get-started/install/windows#run-flutter-doctor -- macOS Terminal (ln): https://www.oreilly.com/library/view/macintosh-terminal-pocket/9781449328962/re11.html -- Windows Command Line (mklink): https://learn.microsoft.com/ko-kr/windows-server/administration/windows-commands/mklink -- Windows PowerShell (New-Item/SymbolicLink): https://learn.microsoft.com/en-us/powershell/module/microsoft.powershell.management/new-item?view=powershell-7.3

댓글

이 블로그의 인기 게시물

Next.js에서 자연스러운 Page Transition 방법

JavaScript Object의 window와 window.opener간 전달할 때 주의할 점!

git flow avh 실행 오류